Degraded performance in trust accounting

Incident Report for Ailo

Resolved

This incident has been resolved.
Posted May 13, 2026 - 15:45 AEST

Investigating

We are currently investigating degraded performance in trust accounting transactions and trust accounting reports
Posted May 13, 2026 - 14:00 AEST
This incident affected: Payments & Transactions.