Ailo apps are currently not available for download on iOS

Incident Report for Ailo

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 15:46 AEDT

Monitoring

Apple has reinstated the apps, and the changes are propagating through the App Store. The app for Property Managers is available again now, however it might still take a few hours for the app for Renters and Property Investors to come back up.

Customers which have already installed the apps and have them on their phones remain unaffected.
Posted Mar 21, 2025 - 13:04 AEDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 21, 2025 - 10:28 AEDT
This incident affected: Core Ailo Apps.