Trust receipting delays

Incident Report for Ailo

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 17:11 AEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 16:56 AEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 03, 2025 - 16:45 AEST

Investigating

Creating trust receipts and balance transfers might be very slow and appear to be stuck in the loading state, caused by a large number of internal events being processed in our backend.
No data has been lost, and the system should be back to the normal state soon.
Posted Jul 03, 2025 - 16:00 AEST
This incident affected: Payments & Transactions.