Can't upload property photos

Incident Report for Ailo

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 15:15 AEST

Identified

A bug is preventing PMs from uploading property photos. We have identified the cause and are currently deploying a fix.
Posted Jul 23, 2025 - 13:55 AEST
This incident affected: Core Ailo Apps.